LTS Help Desk phones appear to be fully functional post-Zoom migration
Resolved
This incident has been resolved.
Posted Feb 12, 2025 - 17:43 EST
Monitoring
We believe that the migration has completed successfully but will monitor till the end of day. Please email helpdesk@lehigh.edu or call 610-758-4993 if you having issues contacting the LTS Help Desk.
Posted Feb 12, 2025 - 13:29 EST
Investigating
On Wednesday, February 12, 2025, the LTS Help Desk phones will be unavailable from 11:00 a.m. to approximately 1:00 p.m. while we upgrade to the new Zoom Workplace environment. Email, chat, and text will continue to be available.

Email: helpdesk@lehigh.edu
Chat: lehigh.edu/ltschat
Text: 610-616-5910

For emergencies, we are offering an option to call a temporary number 610-758-4993, which will be transferred to an LTS Help Desk representative.
Posted Feb 12, 2025 - 11:08 EST
This incident affected: Communication & Collaboration Services, Teaching, Learning, & Research Services, Student Services, Administrative Services, Identity and Account Services, Computing & Infrastructure Services, Software, and Websites.