We are receiving reports that Office products (PowerPoint, Word, Excel) are unavailable
Resolved
This incident has been resolved. If issues persist for you, try the following: 1) reboot, 2) run Windows or MacOS updates, and 3) reboot again. The help desk can step you through the process. Call 610-758.4357.
Posted Feb 10, 2025 - 15:33 EST
Investigating
This appears to affect only downloaded versions of Office, the cloud apps are available. We are currently investigating, check back here for updates. In the interim, it may be helpful to use Google Docs (can export to Office).
Posted Feb 10, 2025 - 10:49 EST
This incident affected: Communication & Collaboration Services, Teaching, Learning, & Research Services, Student Services, Administrative Services, Identity and Account Services, Computing & Infrastructure Services, and Software.